Comment gérer la version de PHP chez OVH, 1and1 et Amen ?

Comment faire pour changer la version PHP d’un serveur chez OVH, 1and1 et Amen ?

De nombreux hébergeurs ont récemment prévenu leurs clients du passage de leurs serveurs à de nouvelles versions de PHP. La mise à jour des serveurs des hébergeurs oblige donc les clients à mettre à jour leur version de PHP, ce qui peut parfois entraîner des problèmes d’affichage sur les sites ou sur les blogs. 1and1 a mis à jour ses serveurs pour passer de PHP 5.2 à PHP 5.4 en 2013. Depuis, 1and1 ne supporte plus PHP 4 et PHP 5.2. Or, WordPress 4.0 nécessite au minimum la version PHP 5.2.4, alors que l’actuelle version stable est PHP 5.5.7. Bref, si vous avez un site ou un blog, il vous faudra à un moment ou à un autre mettre à jour la version PHP du serveur. Comment faire ?

Gérer la version de PHP chez Amen

Pour changer la version PHP d’un serveur chez Amen, il faut tout d’abord se connecter à l’espace client AMEN à l’adresse client.amen.fr

Gérer la version PHP chez Amen

Il faut ensuite se rendre dans la section Hébergement

Gérer la version PHP d un serveur Amen

Enfin, dans la section Configuration, il ne reste plus qu’à cliquer sur le lien Gestion de la version de PHP

changer de version php sur un serveur amen

Le pack AMEN propose différentes versions de PHP. Cliquez sur « installer cette version » pour installer la dernière version de PHP. Amen ne permet que 10 modifications de version PHP par pack.

Gérer la version de PHP sur 1and1

Pour les serveurs clé-en-main de 1and1, il est possible de modifier la version de PHP par .htaccess. Tout d’abord, il faut créer un fichier texte sur l’ordinateur et l’enregistrer sous le nom .htaccess.

Une fois le fichier texte créé, insérez-y les lignes de texte suivantes:

Pour PHP 5.4.x :
AddType x-mapp-php5.4 .php
AddHandler x-mapp-php5.4 .php
Pour PHP 5.5.x :
AddType x-mapp-php5.5 .php
AddHandler x-mapp-php5.5 .php
Pour PHP 5.2.x :
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Il est possible d’inclure d’autres extensions qui seront prises en charge par PHP5 avec cette méthode.

Enfin, enregistrez le fichier puis téléchargez le dans le répertoire qui contient votre site web. Et voilà, votre version PHP a été mise à jour !

Pour les contrats Hébergement Windows de 1and1, la plus récente version de PHP est automatiquement installée. Pour les contrats Hébergement Linux de 1and1, il est possible de choisir la version PHP dans l’Espace Client. Pour cela, rendez-vous dans l’espace client 1&1, puis cliquez sur Réglages PHP dans l’encadré Hébergement.

 

Gérer les version php sur 1and1

Choisissez la version PHP globale, puis cliquez sur Enregistrer.

Gérer les version php sur 1and1

 

Gérer les versions de PHP sur OVH

Pour changer la version PHP d’un serveur OVH, il suffit de déposer le fichier .ovhconfig à la racine de l’espace disque, via FTP. Pour utiliser PHP 5.5 par exemple, ce fichier .ovhconfig devra contenir le code :

app.engine=php
app.engine.version=5.5
http.firewall=none
environment=production

Le fichier .ovhconfig est présent par défaut depuis les Hébergements Web 2014. Sur les offres d’hébergement OVH antérieures, il faudra le créer et le placer à la racine de votre espace disque, sur le même principe que la modification de version PHP par .htaccess sur 1and1.

 

 

Commentez ou posez votre question

Votre email ne sera pas public.